在ubuntu9.04中安装VBoxLinuxAdditions时遇到错误的解决

昨天下完更新包后寝室要熄灯了,于是今天才安装更新。
重启后却提示我ABI major version(4) doesn’t match the server’s version(5),另外还有vboxadd的模块错误。
解决如下:
先在提示的错误框中选择第一个,进入simple模式。进入gnome后,建立一个文件夹~/leniytemp
然后在命令行输入:”sudo ./VBoxLinuxAdditions-x86.run –target ~/leniytemp“,amd64的类似
这次的安装会提示xserver的安装因为版本不匹配安装失败。
然后进入~/leniytemp.
修改文件sudo gedit install.sh.在第415行(Ctrl+I可以查找行号),把1.5.99.* | 1.6 中的1.6换成1.6.0然后保存。
sudo ./install.sh再安装一次,重启。解决问题。

作者: Leniy

Do not , for one repulse , give up the purpose that you resolved to effect .

本文著作版权归Leniy所有,并受法律保护。

转载、使用整体或任何部分的内容(包含但不限于各个页面的标题、评论框提示语)须经过Leniy的授权。

CopyRight © 2006-2017 Leniy.org all rights reserved.

发表评论

电子邮件地址不会被公开。 必填项已用*标注